Язык:Python 1.Выведите на экран числа 1.2, 1.4, 1.6, ..., 2.8.
2.Найдите самый парный элемент списка.
3.Среди элементов с нечетными номерами найдите наибольший элемент списка, который делится на 3.
4.Вывести на экран числа от 1 до 100 которые не делятся на 7.
5.Вывести на экран числа от -11 до 123 не делятся на 5.
6.Вывести на экран четные числа от -8 до 102 не делятся на 5.
7.Вывести на экран нечетные числа от -11 до 99 не делятся на 11.
n = 10;
type
Vector = array[1..n] of integer;
function SumDig(a: Vector): integer;
var
i, m, d, s, max: integer;
begin
s := 0;
for i := 1 to n do
begin
m := a[i];
max := -1;
repeat
d := (m mod 10);
if max < d then max := d;
m := m div 10
until m = 0;
s := s + max
end;
SumDig := s
end;
var
i: integer;
M: Vector;
begin
Writeln('Введите ', n, ' чисел:');
for i := 1 to n do Read(M[i]);
Writeln('Сумма максимальных цифр всех чисел равна ', SumDig(M))
end.
Тестовое решение:
Введите 10 чисел:
613 269 839 10 575 569 812 56 401 616
Сумма максимальных цифр всех чисел равна 65
n = 10;
var
T: array[1..n + 1] of integer;
i, j, k: integer;
begin
Writeln('Введите ', n, ' элементов массива');
for i := 1 to n do Read(T[i]);
Write('Укажите индекс числа и само число для вставки: ');
Readln(j, k);
for i := n downto j do T[i + 1] := T[i];
T[j] := k;
Writeln('Результирующий массив:');
for i := 1 to n + 1 do Write(T[i], ' ')
end.
Тестовое решение:
Введите 10 элементов массива
-5 3 12 81 35 0 43 92 -23 53
Укажите индекс числа и само число для вставки: 4 777
Результирующий массив:
-5 3 12 777 81 35 0 43 92 -23 53