В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alina1932
alina1932
31.05.2020 16:45 •  Информатика

Язык Си 1. Написать программу, которая выдает значение функции
Y = tg(2x) – cos2(x), угол вводится в градусах. Перевод в радианы и поиск значения Y выполнить в функции, куда x передается в виде параметра

2. Посчитать количество элементов массива, больших 120

3. Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0. После ввода нуля, показать на экран их среднее арифметическое

4. Найти среднее арифметическое элементов массива, меньших 0

5. Написать функции, возвращающие максимальный и минимальный элементы массива.

Показать ответ
Ответ:
marinedzhan000
marinedzhan000
28.09.2022 15:29

C++

# include <iostream>

# include <windows.h>

# include <cmath>

# include <iomanip>

# include <fstream>

using namespace std;

int main()

{

  SetConsoleCP(1251);

  SetConsoleOutputCP(1251);

  unsigned char C;

  int kod;

  cout << "Введите символ С: ";

  cin >> C;

  kod = C;

  cout << "Код символа '" << C << "': " << kod << endl;

  system ("pause");

  return 0;

}

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

# include <iostream>

# include <windows.h>

# include <cmath>

# include <iomanip>

# include <fstream>

 

using namespace std;

 

int main()

{

  SetConsoleCP(1251);

  SetConsoleOutputCP(1251);

  unsigned char C;

  int kod;

  cout << "Введите символ С: ";

  cin >> C;

  kod = C;

  cout << "Код символа '" << C << "': " << kod << endl;

 

  system ("pause");

  return 0;

}

0,0(0 оценок)
Ответ:
dariadarina1
dariadarina1
29.11.2021 05:39
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота