В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dianaabilovski
dianaabilovski
24.01.2023 20:20 •  Информатика

Задача А Сортировка массива Время: 1 сек.

Память: 16 Мб

Дан массив А целых неотрицательных чисел, необходимо вернуть массив, состоящий из всех четных элементов A, за которыми следуют все нечетные элементы A.

Вы можете вернуть любой массив ответов, удовлетворяющий этому условию.

Входные данные

В единственной строке входного файла INPUT записан массив А из целых неотрицательных чисел, 1 <= длина массива <= 5000, элементы массива 0 <= A [i] <= 5000.

Выходные данные

В единственную строку выходного файла OUTPUT нужно вывести массив А удовлетворяющий условию.

Пример



INPUT

OUTPUT

1

3,1,2,4

2,4,3,1

Примечание:

Выходные данные [4,2,3,1], [2,4,1,3] и [4,2,1,3] также будут приняты.

Показать ответ
Ответ:
Olenizbugushego
Olenizbugushego
03.12.2020 09:03

Решение ниже. Программа на языке с++.

Объяснение:

#include <stdio.h>

#include <iostream>

#include <locale.h>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int x, i;

   cout << "Введите размерность массива: ";

   cin >> x;

   int* Arr = new int[x];

   cout << "Введите " << x << " элементов массива через пробел: " << endl;

   for (i = 0; i < x; i++)

   {

       cin >> Arr[i];

   }

   

   cout << endl << "ответ: ";

   

   for (i = 0; i < x; i++)

   {

       if (Arr[i] % 2 == 0)

       {

           cout << Arr[i] << " ";

       }

   }

   

   for (i = 0; i < x; i++)

   {

       if (Arr[i] % 2 != 0)

       {

           cout << Arr[i] << " ";

       }

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота