В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
opuros33
opuros33
24.02.2020 21:18 •  Информатика

Задание: Напишите программу, которая в последовательности чисел определяет максимальное число, оканчивающееся на 1. На вход программа получает числа: 3, 11, 21, 31. Количество чисел не превышает 1000. Величина чисел не превышает 30000.
Я пишу программу:
var n, a, i:integer;
begin
readln(n);
min(n) :=30001; (вот здесь он ругается "нельзя присвоить левой части")
for i:=1 to n do
begin
readln(a);
if (a mod 16 = 0) and (a then min:=a;
end;
writeln(min);
end.

Что не так??? Объясните И если есть еще ошибки, исправьте

Показать ответ
Ответ:
Rj7
Rj7
06.05.2023 15:31

То же задание, только другой вывод? Ну, вот например, несколько вариантов (все выводят одно и то же- ну, если конечно на вход подавать число, указанное в задании, а не что попало :)

1) текстовый вариант (запрашиваемое число вводится сразу в текстовом виде):

алг

нач

лит т

вывод "Введите четырёхзначное число",нс

ввод т

вывод т[1],"+",т[2],"=",Цел(т[1],0)+Цел(т[2],0),", "

вывод т[3],"*",т[4],"=",Цел(т[3],0)*Цел(т[4],0)

кон

2) числовой вариант (простой):

алг

нач

цел а,б,в,г,д

вывод "Введите четырёхзначное число",нс

ввод а

д:=mod(а,10);а:=div(а,10)

г:=mod(а,10);а:=div(а,10)

в:=mod(а,10);а:=div(а,10)

б:=mod(а,10)

вывод б,"+",в,"=",б+в,", ",г,"*",д,"=",г*д

кон

3) числовой вариант (так себе):

алг

нач

цел а,ц

цел таб т[1:4]

вывод "Введите четырёхзначное число",нс

ввод а

нц для ц от 1 до 4

т[ц]:=mod(а,10)

а:=div(а,10)

кц

вывод т[4],"+",т[3],"=",т[4]+т[3],", ",т[2],"*",т[1],"=",т[2]*т[1]

кон

4) число-текстовый вариант (ерунда какая то, типа если не очень то, что в первом варианте число вводится как текст) -цикл перевода сделан для разнообразия, и так то заменяется одним алгоритмом, переводящим всё число сразу- цел_в_лит(а),  при этом и начальное значение  т  задавать не надо.

алг

нач

цел а

лит т=""

вывод "Введите четырёхзначное число",нс

ввод а

нц 4 раз

т:=символ(48+mod(а,10))+т

а:=div(а,10)

кц

вывод т[1],"+",т[2],"=",Цел(т[1],0)+Цел(т[2],0),", "

вывод т[3],"*",т[4],"=",Цел(т[3],0)*Цел(т[4],0)

кон

5) числовой вариант (непойми что и сбоку бантик):

алг

нач

цел а,б,в,н,ц

цел таб т[1:4]

вывод "Введите четырёхзначное число",нс

ввод а

нц для н от 1 до 4

а:=mod(а,10**(5-н))

т[н]:=div(а,10**(4-н))

в:=т[н]

ц:=div(н,4)

если 2*ц=н-2 то

вывод б,символ(43-ц),в,"=",б+в-(б+в-б*в)*ц,символ(44-12*ц)," " все

б:=т[н]

кц

кон


Написать программу на языке Кумир: Для введенного с клавиатуры четырехзначного числа найти сумму дву
0,0(0 оценок)
Ответ:
margarita4278
margarita4278
19.10.2021 22:39

1) 16 Кбайт = 2⁴ Кбайт = 2⁴ * 2¹⁰ байт = 2¹⁴ байт = 2¹⁴ * 2³ бит = 2¹⁷ бит

2) 2¹⁵ Кбайт = 2¹⁵ / 2¹⁰ Мбайт = 2⁵ Мбайт

3) 2¹⁷ бит = 2¹⁷ / 2³ байт = 2¹⁴ байт = 2¹⁴ / 2¹⁰ Кбайт = 2⁴ Кбайт

4) 32 Гбайта = 2⁵ Гбайт = 2⁵ * 2¹⁰ Мбайт = 2¹⁵ Мбайт = 2¹⁵ * 2¹⁰ Кбайт = 2²⁵ Кбайт

5) 2²³ байт = 2²³ / 2¹⁰ Кбайт = 2¹³ Кбайт = 2¹³ / 2¹⁰ Мбайт = 2³ Мбайт

6) 64 Мбайта = 2⁶ Мбайт = 2⁶ * 2¹⁰ Кбайт = 2¹⁶ Кбайт = 2²⁶ * 2³ бит = 2²⁹ бит

Объяснение:

1 байт = 8 бит = 2³ бит

1 Кбайт = 1024 байт = 2¹⁰ байт

1 Мбайт = 1024 Кбайт = 2¹⁰ Кбайт

1 Гбайт = 1024 Мбайт = 2¹⁰ Мбайт

При переводе больших единиц в меньшие используем умножение. При умножении степени с одинаковым основанием складываем.

При переводе меньших единиц в большие используем деление. При делении степени с одинаковым основанием вычитаем.

6) 64 Мбайта = 2⁶ Мбайт = 2⁶ * 2¹⁰ Кбайт = 2¹⁶ Кбайт = 2¹⁶ * 2¹⁰ байт = 2²⁶ байт = 2²⁶ * 2³ бит = 2²⁹ бит

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота