В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ящерка618
Ящерка618
12.09.2020 19:47 •  Информатика

Задание по Информатике в программе Access Нужно сделать 6 таблиц, связать их, сделать 1 запрос и 1 форму. Тема любая.
если не сложно

Показать ответ
Ответ:
barbara27
barbara27
18.10.2020 18:42

program a2;

var

 a, x1, y1, z1, l1, z, l: string;

 i, g, d, f, a1, b1, sum, vr, vr1, err: int64;

begin

 readln(a);

 g := pos(';', a);

 x1 := copy(a, 2, g - 2);

 y1 := copy(a, g + 2, length(a) - g - 2);

 if a[1] = '[' then d := 1

 else d := 0;

 if a[length(a)] = ']' then f := 1

 else f := 0;

 if pos('/', x1) <> 0 then begin

   z := copy(x1, 1, pos('/', x1) - 1);

   z1 := copy(x1, pos('/', x1) + 1, length(x1) - pos('/', x1));

   val(z, vr, err);

   val(z1, vr1, err);

   a1 := vr div vr1;

 end

 else val(x1, a1, err);

 if pos('/', y1) <> 0 then begin

   l := copy(y1, 1, pos('/', y1) - 1);

   l1 := copy(y1, pos('/', y1) + 1, length(y1) - pos('/', y1));

   val(l, vr, err);

   val(l1, vr1, err);

   b1 := vr div vr1;

 end

 else val(y1, b1, err);

 for i := a1 to b1 do sum := sum + 1;

 val(z, vr, err);

 val(z1, vr1, err);

 if (d = 0) then  

   if vr = 0 then sum := sum - 1

   else if (vr mod vr1 = 0) then sum := sum - 1;

 val(l, vr, err);

 val(l1, vr1, err);

 if (f = 0) then  

   if vr = 0 then sum := sum - 1

   else if (vr mod vr1 = 0) then sum := sum - 1;

 writeln(sum);

end.

На не благодари)

0,0(0 оценок)
Ответ:
GameNooB
GameNooB
28.05.2022 09:04

program z1;//имя программы

var a:real;b,c,d:integer;//объявление глобальных переменных

function M (x,y:integer): integer;//название функции, параметры, тип результата

begin//тело функции

if x>y then M:=x else M:=y//неполный условный оператор

end;

begin//тело программы

read (a,b);//ввод значений переменных

if frac(a) >= 0.5 then c:=trunc(a)+1 else c:=trunc(a);//математическое округление

d:= M (b,c);//вызов функции

write(d)//вывод результата

end.

Объяснение:

картинка 1 - блок-схема программы

картинка 2 - блок-схема функции

математическое округление, чтобы 2,5 было равно 3, а не 2 как при использовании функции round


Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота