Задание
1. Составьте программу, в которой определяется сумма цифр S данного натурального числа n (для n = 1234 S = 10; для n = 20056 S = 13).
2. Составьте программу, которая определяет, является ли введённое натуральное число число не имеет других делителей, кроме единицы и самого себя число; 12 – не является При написании программы может оказаться полезной команда break; – принудительное окончание цикла.
3. Напишите программу, в которой определяются и выводятся на экран все делители данного натурального числа N и подсчитывается их количество k.
Ограничьтесь значениями N ≤ 100; единицу и само число учитывать как делители не нужно.
(Делители 36: 2, 3, 4, 6, 9, 12, 18; k = 7. Делители 66: 2, 11, 33; k = 3. Делители 29: нет.)
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
down;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
down;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
down;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
down;
1.
program test;
var i,k2,k3,k4,k5:integer;
a:array [1..20] of integer;
begin
k2:=0;
k3:=0;
k4:=0;
k5:=0;
for i:=1 to 20 do
begin
a[i]:=random(4)+2;
if a[i]=2 then k2:=k2+1;
if a[i]=3 then k3:=k3+1;
if a[i]=4 then k4:=k4+1;
if a[i]=5 then k5:=k5+1;
write(a[i],' ')
end;
writeln;
writeln(k2);
writeln(k3);
writeln(k4);
write(k5)
end.
2.
var i,j,v:integer;
a:array [1..10] of integer;
begin
for i:=1 to 10 do
begin
a[i]:=random (100);
write(a[i]:3)
end;
for i:=1 to 9 do
for j:=1 to 9 do
if a[j]>a[j+1] then
begin
v:=a[j];
a[j]:=a[j+1];
a[j+1]:=v
end;
writeln;
for i:=1 to 10 do write(a[i]:3)
end.
3.
var a:array [1..10] of integer;
i,j,m,v:integer;
begin
randomize;
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i]:3)
end;
writeln;
for i:=1 to 10 do
begin
m:=i;
for j:=i to 10 do
if a[m] mod 10 < a[j] mod 10 then m:=j;
v := a[i];
a[i]:= a[m];
a[m] := v;
write(a[i]:3)
end;
end.