В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kalymkulovramaz
kalymkulovramaz
07.07.2022 14:10 •  Информатика

Задания 1. Составьте программу, используя среду программирования. Если акула касается курсора, тогда выходит сообщение «Догнала курсор. Он невкусный». Иначе выходит сообщение: «Курсор быстрый. Не могу догнать.» Скрипт для акулы: а) Добавьте в скрипт звук.

Показать ответ
Ответ:
happycatcom
happycatcom
25.11.2020 09:54
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var t:=ReadlnString(':').MatchValue('\(.*\)');
  Writeln(t[2:t.Length])
end.

Пример
: Напечатаем только то (что в скобках) и не более!
что в скобках

Пояснения.
1) Принимаем с клавиатуры текстовую строку, выделяем в ней пару круглых скобок вместе с содержимым и помещаем полученную подстроку в t. В соответствии с условием считаем без проверки, что такая пара скобок есть всегда.
2) Выделяем из содержимого t символы со второго по предпоследний (т.е. скобки не включаем) и выводим результат на экран.
0,0(0 оценок)
Ответ:
Miratrix
Miratrix
05.10.2022 19:31
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p:=ArrRandom(200,-99,99); p.Println;
  Writeln('Числа, кратные трем');
  p.Where(k->k mod 3=0).Println;
  Writeln('Сумма положительных равна ',p.Where(k->k>0).Sum)
end.

Пример
-46 86 -75 83 87 -17 -23 -46 -95 8 19 -2 -93 -18 -47 65 66 81 77 79 30 -40 -76 99 -19 67 -39 25 21 65 64 49 54 -9 18 -98 -43 84 76 -9 64 53 86 -48 -77 -51 -93 22 -31 76 -93 86 -45 -94 92 93 62 -74 3 -79 -77 52 33 -61 44 69 43 15 63 -48 8 82 -94 -14 -84 76 -27 72 76 -67 60 38 -44 45 59 78 -6 48 -1 24 -61 -68 -18 55 -31 -88 -79 48 7 -46 5 -8 58 -82 -31 -75 80 69 90 -83 21 90 -51 -30 -39 -16 -3 87 -20 66 -25 94 -84 -61 -87 -24 0 -50 -82 -96 55 25 -35 23 27 -31 80 -62 -23 34 97 25 58 -17 -96 -51 83 -88 -5 85 15 -67 -31 41 78 11 -24 19 -95 92 24 30 52 86 -39 96 25 26 43 91 3 -41 11 45 68 50 -64 33 -64 64 -7 -11 55 -68 -12 22 -43 24 44 -83 92 -38 -67 -16 -89 -32 73 71 -77 -93
Числа, кратные трем
-75 87 -93 -18 66 81 30 99 -39 21 54 -9 18 84 -9 -48 -51 -93 -93 -45 93 3 33 69 15 63 -48 -84 -27 72 60 45 78 -6 48 24 -18 48 -75 69 90 21 90 -51 -30 -39 -3 87 66 -84 -87 -24 0 -96 27 -96 -51 15 78 -24 24 30 -39 96 3 45 33 -12 24 -93
Сумма положительных равна 5671
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота