В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sherilblo
sherilblo
30.11.2020 16:54 •  Информатика

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры). входные данные: в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). во второй строке целые числа х1, разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива. выходные данные: сумма элементов массива c номерами от i1 до i2. (написать программу на паскале)

Показать ответ
Ответ:
Амбрела123
Амбрела123
20.06.2020 21:23
Var
 a:array [1..100] of longint;
 N,i1,i2,i,S:longint;
begin
 Read(N,i1,i2);
For i:=1 to N do Read(a[i]);
For i:=i1 to i2 do S:=S+a[i];
Write(S);
end.
0,0(0 оценок)
Ответ:
6676228
6676228
20.06.2020 21:23
За такую программу писать лень:D
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота