В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mstella2003
mstella2003
19.11.2022 02:44 •  Информатика

1: составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с нечетными значениями. 2: составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с четными положительными значениями.

Показать ответ
Ответ:
dimas112006
dimas112006
01.10.2020 11:22
З1:
Program z;
var mas: array [1..10] of integer;
i, x: integer;
begin
for i:=1 to 10 do
readln(mas[i]);
for x:=1 to 10 do
if mas[x] mod 2 = 1 then writeln(mas[x]);
end.
З2:
Program z;
var mas: array [1..10] of integer;
i, x: integer;
begin
for i:=1 to 10 do
readln(mas[i]);
for x:=1 to 10 do
if (mas[x] mod 2 = 0) and (mas[x] > 0) then writeln(mas[x]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота