В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
milna1
milna1
04.06.2020 10:33 •  Информатика

C++ Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.

Примеры
входные данные
5
выходные данные
101

входные данные
-14
выходные данные
-1110

Показать ответ
Ответ:
lidiyamartin9
lidiyamartin9
09.02.2021 16:43

Код программы:

#include <iostream>

#include <locale>

#include <time.h>

using namespace std;

int bit(int a) {

int sum = 0, p = 1;

while (a) {

 sum += p * (a % 2);

 p *= 10;

 a /= 2;

}

return sum;

}

int main()

{

setlocale(LC_ALL, "Russian");

int a;

cout << "Введите число: ";

cin >> a;

cout<<"Число в 2-ой системе счисления: "<<bit(a)<<endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота