В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

CРОЧНО
Написать программу вычисления среднего арифметического величин x1, x2 и x3. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление среднего арифметического.

Введите исходные данные:

Величина x1 -> 6.9

Величина x2 -> 2.1

Величина x3 -> 3

Среднее арифметическое: 4.

Показать ответ
Ответ:
rrus2057
rrus2057
14.04.2021 22:33
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,n,i,s:integer;
begin
  write('Число элементов последовательности ');
  readln(n);
  for i:=1 to n do begin
    write(i,' элемент последовательности = ');readln(a);
    if (a mod 2 <>0) then s:=s+a;
  end;
  writeln('Сумма нечетных = ',s);
 end.

Тестовое решение:
Число элементов последовательности 5
1 элемент последовательности = 3
2 элемент последовательности = 2
3 элемент последовательности = 4
4 элемент последовательности = 1
5 элемент последовательности = 5
Сумма нечетных = 9
0,0(0 оценок)
Ответ:
оарташ
оарташ
05.05.2023 00:30

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота