В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bonusalixova
bonusalixova
05.03.2021 08:18 •  Информатика

Дан массив а, состоящий из 6 элементов. вывести элементы массива. изменить порядок следования элементов массива на обратный, вывести инвертированный массив. , , составить программу в ! вот, например, я начала. program z10; var p, i: integer; x: array [1..6] of integer; begin for i: =1 to 6 do begin p: =a[i]; а как дальше поменять местами остальные элементы? ?

Показать ответ
Ответ:
ИЗЫДИ666
ИЗЫДИ666
26.06.2020 16:02
1)
просто выводим элементы наооборот
program gt;
var a:array[1..6]of longint;
n,i:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
for i:=6 downto 1 do
begin
write(a[i],' ');
end;
end.
2)
добавляем дополнительный массив b
program gt;
var a,b:array[1..6]of longint;
n,k,i:integer;
begin
read(n);
k:=7;
for i:=1 to n do
begin
read(a[i]);
k:=k-1;
b[k]:=a[i];
end;
for i:=1 to 6 do
begin
write(b[i],' ');
end;
end.
3)
Изменяем элементы массива без дополнительных элементов
Program z10;
VAR 
p, i: Integer; 
x: Array [1..6] of integer;
Begin
For i:=1 to 3 Do 
begin
p:=a[i];
a[i]:=a[6-i+1];
a[6-i+1]:=p;
end;
for i:=1 to 6 do
begin
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота