В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Котанская
Котанская
21.03.2020 03:57 •  Информатика

Дан одномерный массив целых чисел.написать программу подсчёта количества положительных и отрицательных чисел массива.

Показать ответ
Ответ:
ziketeam123
ziketeam123
02.10.2020 06:25
Var ar : array [1..100] of integer;
i, pluscount,minuscount,zerocount : integer;
begin
readln(n); -считываем число элементов массива(если оно дано, я не знаю)
for i := 1 to n do
begin
read(ar[i]);  - считываем элемент массива, заносим его в массив
if (ar[i] > 0) then pluscount := pluscount+1; -если >0 -> увел. счетчик пол.чисел
if (ar[i] < 0) then minuscount := minuscount+1; -если <0 -> увел. счетчик отр.чисел
if (ar[i] = 0) then zerocount := zerocount+1; -если =0 -> увел. счетчик нулей
end;
writeln('В массиве ',pluscount,' положительных чисел, ',minuscount,' отрицательных чисел, ',zerocount,' нулей.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота