В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
AbraevAidar
AbraevAidar
19.07.2020 21:12 •  Информатика

Дано натуральное число.напишите программу,которая проверяет, является ли оно четырехзначным и расположены ли его цифры в порядке убывания.

Показать ответ
Ответ:
sotlen61Ang
sotlen61Ang
09.10.2020 23:19

var

 n, i: Integer;

 s: string;

 isu: Boolean;

begin

 Write ('Введите число: ');

 Read (n);

 if (n >= 1000) and (n <= 9999) then

   WriteLn ('Это число четырехзначное')

 else

   WriteLn ('Это число не четырехзначное');

 s := IntToStr (n);

 isu := True;

 for i := 1 to Length (s) - 1 do begin

   if s [i] <= s [i + 1] then begin

     isu := False;

     Break;

   end;

 end;

 WriteLn;

 if Isu then

   WriteLn ('Цифры расположены в порядке убывания')

 else

   WriteLn ('Цифры НЕ расположены в порядке убывания');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота