В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Pashayka
Pashayka
27.11.2022 22:49 •  Информатика

Известны три натуральных числа c– часы, m – минуты, s – секунды. написать программу используя условный оператор, которая определяет время через 15 секунд. нужно сделать через pascal !

Показать ответ
Ответ:
Fezit
Fezit
09.07.2020 22:28
Var
c,m,s:integer;
begin
readln(c,m,s);
if s>=45 then begin
m:=m+1;
s:=s+15-60;
end
else s:=s+15;
if m>=59 then begin
 c:=c+1;
m:=0;
end;
if c>=24 then c:=0;
writeln(c,' ',m,' ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота