В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tatyanabelousova
tatyanabelousova
23.02.2021 21:05 •  Информатика

Написать программу c++ cin cout (Двумерные массивы) Условие
Требуется определить количество выплаты n рублей монетами по 1, 2, 5 и 10 рублей.

входные данные выходные данные
13 16
42 220
5 4

Показать ответ
Ответ:
franktyoma
franktyoma
13.06.2021 16:25

#include <iostream>

using namespace std;

int a[4] = {1, 2, 5, 10}, b = sizeof(a)/sizeof(a[0]), m[100];

 

int f(int s, int j = 0, int k = 0) {    

   if (j >= b || s < 0)

       return 0;

   else if (s == 0) {

       for(int i=0; i<k; i++)  

           return 1;

   } else {

       m[k]=a[j];  

       return f(s - a[j], j, k + 1) + f(s, j + 1, k);

   }

}

int main() {

 int n; cin >> n;

 cout << f(n);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота