Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Danila5535
18.05.2020 01:24 •
Информатика
Написать программу, где вводиться число и находитьяс сумма цифр(паскаль, или lazarus)
Показать ответ
Ответ:
mariabrin27
08.10.2020 06:49
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
write('сумма цифр: ',abs(ReadInteger('введите число:')).ToString.Select(x->x.ToDigit).Sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Небатан1542
08.02.2022 15:15
Это устройство предназначено для хранения информации произвольного доступа. Является основным накопителем данных в большинстве компьютеров...
seal2004
14.09.2022 18:47
Каким образом можно сравнивать файлы с одинаковым содержимым, но в разных форматах?...
ЖеняРай
02.08.2020 09:52
Сынсыз желі дегеніміз не ...
Markos14
10.07.2020 08:31
К образовательным электронном ресурсом относится: 1. Монитор 2. презентации 3. учебники 4. рефераты 5. жёсткий диск...
ivanovartem450p08ajg
25.08.2020 15:08
Заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку, заменив положительные элементы на число 0....
Yarik200825
18.07.2020 17:37
Написать программу вычисляющую значение x,если: x=(5+a (b--5d)...
samira2314
31.05.2022 08:40
Чертёжнику был дан для использования следующий алгоритм повтори 5 раз сместиться на (0,1),сместиться на (-1,4) сместиться на (3,-6)конец....
7Dancho
29.11.2022 03:04
Дано целое число. Если оно является положительным, то прибавить к нему 41; в противном случае не изменять его. Вывести полученное число.а)program cislo;vara: integer;beginwriteln(...
alanada1
11.08.2020 15:41
Как называется знак который находится в главном меню в пункте служебные Windows изображённый на картинке...
danikvorona
05.02.2021 11:44
В классе 30 учеников. Каждый из них должен посещать хотя бы один кружок: математику, русский язык, физику, информатику. Физику и русский язык посещают 11 учеников. Математику...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1634
begin
write('сумма цифр: ',abs(ReadInteger('введите число:')).ToString.Select(x->x.ToDigit).Sum);
end.