В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
макс3102
макс3102
23.02.2021 09:21 •  Информатика

Написать программу, которая спрашивает у пользователя число, после этого выводит строку типа: 2 компьютера. В зависимости от введенного числа, программа должна корректно подставлять окончание для слово компьютер Пример:

Ввод: Пользователь ввел число 12

Вывод: 12 компьютеров
(Код должен работать с любым числом)

Показать ответ
Ответ:
Krutoi0chuvak
Krutoi0chuvak
15.01.2022 23:20

n = int(input("введи число"))

if n%10== 1:

print(n,"компьютер")

elif (n%10==2 or n%10==3 or n%10==4):

print(n,"компьютера")

else:

print(n,"компьютеров")

0,0(0 оценок)
Ответ:
WhiteFix
WhiteFix
15.01.2022 23:20

Объяснение:

язык программирования (С++)

int main() {int a;cin>> a; if (a<4) {cout << a " компьютерa " ;}else {cout<< a"компьютеров"} return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота