Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
НемфодораТ
18.01.2022 16:07 •
Информатика
Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое. на паскале (через for to do)
Показать ответ
Ответ:
areg122004
07.10.2020 01:07
Текст программы + результат тестирования
var a, b, c: real;
i : integer;
begin
b:=0;
for i:=1 to 5 do
begin
write('Введите число: ');
read(a);b:=b+a;
end;
c:= b/i;
writeln('Среднее арифметическое значение чисел: ', c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Danyaizbanu
12.09.2022 19:56
Напишите программу увеличивающую каждый элемент матрицы (n,m) в 3 раза и сохраняющую результат в виде второй матрицы...
19Табуретка48
02.04.2022 11:47
Даны два целых числа. определить, какое из них больше или определить их равенство. вывести знак если первое число больше, знак если второе число больше, знак =...
Валерыч2005
30.06.2021 00:41
Решить : в каждом из четырёх углов комнаты стоит комп.напротив каждого из этих компьютеров также стоит комп.сколько всего в этой комнате компов?...
Sima121
30.06.2021 00:41
Паскаль, ! дан фрагмент программы, который решает поиска номера последней минимальной цифры в записи десятичного целого числа (считается, что цифры в числе пронумерованы...
rimolol
06.03.2021 21:39
Составьте программу которая заполняет массив b 1..8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример...
abcdefgh
06.03.2021 21:39
1)напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. программа получает на вход...
Юля9887
28.05.2021 18:08
Ввести своє прізвище. вивести його горизонтально з проміжком між буквами (паскаль)...
Lups
08.03.2022 16:03
Укажите наименьшее четырёхзначное восьмеричное число двоичная запись которого содержит 6 единиц. в ответе запишите только само восьмеричное число, основание системы...
Arina111933
26.05.2022 10:00
Напишите программу для решения квадратных неравенств на языке pascal. ax^2 + bx +c ( ; ≤; ; ≥) 0 нужна ! заоанее ...
famm2
04.07.2021 12:17
Производительность труда штукатура составляет а( м2/ч),маляра-в (м2/ч) и облицовщика - с (м2/ч). составить алгоритм длявычисления площади обработки поверхностей...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a, b, c: real;
i : integer;
begin
b:=0;
for i:=1 to 5 do
begin
write('Введите число: ');
read(a);b:=b+a;
end;
c:= b/i;
writeln('Среднее арифметическое значение чисел: ', c);
end.