В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
buh64
buh64
12.03.2022 01:39 •  Информатика

Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. если первая цифра равна четвёртой, а третья второй, то выводит на экран "палиндорм", а в противном случае "не палиндорм".

Показать ответ
Ответ:
sashagorchakova
sashagorchakova
15.09.2020 23:39
Var
  a:integer;
begin
  write('Введите число ');
  readln(a);
  if (a div 1000 = a mod 10) and ((a div 100)mod 10 =(a div 10)mod 10)then
  writeln('Палиндром')
  else writeln('не Палиндром');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота