В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. pascal abc

Показать ответ
Ответ:
ilhamamanov197
ilhamamanov197
08.10.2020 21:14

var

    s: string;


function Invert(s: string): string;

var

    i: integer;

    t: string;

begin

    t := '';

    for i := 1 to length(s) do

        t := s[i] + t;

    

    Invert := t;

end;


begin

    Write('Введите слово: ');

    Readln(s);

    

    s := Trim(s);

    s := Uppercase(s);

    

    if Invert(s) = s then 

        Writeln('Палиндром')

    else 

        Writeln('Не палиндром');

end.

0,0(0 оценок)
Ответ:
isanatoliy25199
isanatoliy25199
08.10.2020 21:14
Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите слово: ');
  Readln(s);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота