В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на языке Pascal.ABC задача1
даны катеты прмоугольного треугольника а и b. найти его гипотенузу с, периметр Р и площадь S
задача2
найти длину окружности L и площадь круга S заданного радиуса R. (L=2пR; S=пR^2; считать, что п =3,14) ​

Показать ответ
Ответ:
vovasherbak2003
vovasherbak2003
13.12.2020 22:50

1)

program tr;

var a,b,c,S,P:double;

begin

write('Введите 2 катеты: ');

read(a);

read(b);

c:=Sqrt((a*a)+(b*b));

writeln('Гипотенуза -',c:6:2);

P:=a+b+c;

writeln('Периметр - ',P:6:2);

S:=(a*b)/2;

writeln('Площадь - ',S:6:2);

end.

2)

program kr;

var a,b,c,S,PI,L,R:double;

begin

PI:=3.14;

write('Введите радиус: ');

read(R);

L:=2*PI*R;

writeln('Периметр - ',L:6:2);

S:=PI*Sqr(R);

writeln('Площадь - ',S:6:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота