В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
muralova
muralova
01.05.2020 12:20 •  Информатика

Написать программу по паскалю,. известно, что коды прописных (заглавных) букв латинского алфавита следуют в таблице непрерывно друг за другом. коды строчных букв латиницы также следуют непрерывно друг за другом на расстоянии 32 символов от прописных (ниже по таблице) . если ord('a') = 65, то ord('a')+32 = 97, и это код строчной буквы «а» , то есть chr(ord('a')+32) = 'а'. напишите программу, в которой вы вводите прописную букву (только латиницу! ) , а получаете ее строчной эквивалент, и наоборот, по строчной букве получаете соответствующую прописную.

Показать ответ
Ответ:
Костя111113
Костя111113
07.07.2020 15:17
Var c:char;
begin
readln(c);
if ord(c)<97 then
   c:=chr(ord(c)+32)
   else c:=chr(ord(c)-32);
writeln(c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота