В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
OlesyLisaGames
OlesyLisaGames
10.02.2020 05:59 •  Информатика

Написать программу в pascal, которая сортирует массив и находит количество различных чисел в нём

Показать ответ
Ответ:
катяипапа000111
катяипапа000111
07.10.2020 07:20
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  a.Sort; a.Println;
  Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.

Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота