В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
raisaaaaaaaaaaaa
raisaaaaaaaaaaaa
06.03.2020 03:20 •  Информатика

Написать программу в паскаль ввести текст состоящий из слов , разделённых между собой запятыми. сколько раз в тексте встречается слова "мама" в найденных словах изменить букву "м" на букву "п" так же нужно прописать программу простую и понятную по синтаксису

Показать ответ
Ответ:
bersenevaksenia1
bersenevaksenia1
04.10.2020 23:13
//PascalABC.NET версия 3.2, сборка 1367
begin
    var s := ReadlnString('>');
    var r := new Regex('\bМама\b');
    Writeln('Количество слов "Мама": ', r.Matches(s).Count);
    s := r.Replace(s, 'Пама');
    s.Println;
end.

все просто и понятно)
только экранирующие символы пришлось поискать для слова целиком

Пример работы программы:
> Мама,Мамам,Мама,мама,Мама
Количество слов "Мама": 3
Пама,Мамам,Пама,мама,Пама
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота