В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
NEASA
NEASA
14.09.2022 04:34 •  Информатика

Напишите программу и составьте блок схему к следующей задаче: с клавиатуры вводится произвольное четырёх значное целое число. найдите произведения цифр числа и разность второй и третьей цифр этого числа

Показать ответ
Ответ:
Milanusia
Milanusia
14.02.2020 15:16
Procedure Replace(var s: string; c: char);
var
  i: integer;
  Lett: set of char;
begin
  Lett := ['A'..'z', 'А'..'я'];
  for i := 1 to Length(s) do
    if s[i] in Lett then s[i] := LowCase(s[i])
    else s[i] := c
end;

var
  s1, s2: string;

begin
  write('Введите первую строку: ');
  readln(s1);
  write('Введите вторую строку: ');
  readln(s2);
  Replace(s1, '$');
  Replace(s2, '_');
  writeln(s1);
  writeln(s2)
end.

Тестовое решение:

Введите первую строку: Карл у Клары украл кораллы, а Клара у Карла... украла кларнет! 1+2+3+4+5=15 По-моему так!
Введите вторую строку: "Colorless green ideas sleep furiously"/ (Noam Chomsky, 1957).
карл$у$клары$украл$кораллы$$а$клара$у$карлаукрала$кларнетпо$моему$так$
_colorless_green_ideas_sleep_furiouslynoam_chomsky
0,0(0 оценок)
Ответ:
ZMelnikSasha
ZMelnikSasha
20.03.2023 08:50
Program ex1;

const
  n = 10;

var
  a: array[1..n] of integer;
  kOdd, e, i: integer;

begin
  Randomize;
  kOdd := 0;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    e := Random(20) + 1;
    a[i] := e;
    if (e mod 2) <> 0 then kOdd := kOdd + 1;
    write(e:3)
  end;
  writeln;
  writeln('Количество нечетных элементов - ', kOdd)
end.

Тестовое решение:
Исходный массив   9  2  1 18 17 16 11 15 15 13
Количество нечетных элементов - 7

program ex2;

const
  n = 10;

var
  a: array[1..n] of integer;
  kNeg, e, i: integer;

begin
  Randomize;
  kNeg := 0;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    e := Random(21) - 10;
    a[i] := e;
    if e < 0 then kNeg := kNeg + 1;
    write(e:4)
  end;
  writeln;
  writeln('Количество отрицательных элементов - ', kNeg);
end.

Тестовое решение:
Исходный массив   -9  -1  -7  -4   8  -4   1  -1  -7   0
Количество отрицательных элементов - 7

program ex3;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(20);
    write(a[i]:4)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] mod 2 = 0 then a[i] := 1;
    write(a[i]:4)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив    3  16   4   1  13   0  14  14  10  18
Результирующий массив    3   1   1   1  13   1   1   1   1   1

program ex4;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(11) + -5;
    write(a[i]:4)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] = 0 then a[i] := 1;
    write(a[i]:4)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив    4  -5   0  -2  -4  -5  -2   0  -1  -5
Результирующий массив    4  -5   1  -2  -4  -5  -2   1  -1  -5

program ex5;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(10) + 1;
    write(a[i]:3)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] = 3 then a[i] := 5;
    write(a[i]:3)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив   8  9  6 10 10  7  1  3  1  3
Результирующий массив   8  9  6 10 10  7  1  5  1  5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота