В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
arelbeis
arelbeis
08.06.2022 04:59 •  Информатика

Напишите программу, которая решает следующую , используя логические операции и сдвиги:
при кодирование цвета используются 4-битные значения составляющих r (красная), g (зеленая) и b (синяя). коды этих составляющих записаны в регистрах r1, r2 и r3. построить в регистре r0 полный код цвета. например, если r1=a16, r2=b16 и r3=c16, в регистре r0 должно получиться число abc16

Показать ответ
Ответ:
Екатерина21082006
Екатерина21082006
27.11.2020 12:36
пропуски в тексте: База данных - это

, предназначенный(-ая) для длительного хранения во внешней памяти компьютера и постоянного применения.
Система управления базами данных - это

, предназначенный(-ая) для работы с БД.
База данных, основанная на табличной форме организации данных называется

.
В такой базе данных столбец называется

, а строка -

.
Поле, позволяющее сделать каждую запись уникальной, называют

.

реляционная, организованная совокупность данных, иерархической, информационная система, произвольный набор информации, первым, программа, ключевым, полем, записью, ячейкой

Все ответы проверяются

30000
ДОБАВИТЬ ОТВЕТ
0,0(0 оценок)
Ответ:
НЕВЕСОМАЯ67
НЕВЕСОМАЯ67
23.04.2023 06:35

// В вашем коде сразу бросается в глаза деление 1 / (i * i). Тут 1, i -- это int => i*i тоже int. В итоге делим int на int. И результат получаем соответствующий. Обязательно узнайте про целочисленное деление

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           Console.Write("Enter n: ");

           int n = int.Parse(Console.ReadLine());

           if (n < 1)

           {

               Console.WriteLine("incorrect value");

               return;

           }

           double res = 1;

           for (int i = 1; i <= n; i++)

               res *= 1 + 1 / Math.Pow(i, 2);

           Console.WriteLine($"Result: {res}");

           Console.ReadLine();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота