В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kirakler2000
Kirakler2000
17.09.2021 10:53 •  Информатика

Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. при вводе неверного месяца должно быть выведено сообщение об ошибке.

Показать ответ
Ответ:
oksankavelsh
oksankavelsh
20.08.2020 15:16
Var a,b,c,d,e:real;
begin
b := 30;
c := 31;
d := 29;
e := 28;
writeln('От 1 до 12');
readln(a);
if a = 1 then writeln(c);
if a = 2 then writeln(d,' или ',e);
if a = 3 then writeln(c);
if a = 4 then writeln(b);
if a = 5 then writeln(c);
if a = 6 then writeln(b);
if a = 7 then writeln(c);
if a = 8 then writeln(c);
if a = 9 then writeln(b);
if a = 10 then writeln(c);
if a = 11 then writeln(b);
if a = 12 then writeln(c);
else writeln('Неправильно');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота