Напишите программу на чистом С для решения задачи: Каждая строка в двумерной матрице представляет собой восьмеричное число (элементы строки могут принимать только значения от нуля до семи). Найти строку с минимальным числом и сформировать новую матрицу путем вычитания найденного числа из всех остальных строк.
var x : array[1..n] of real;
i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
x[i]:=20*random-10;
write(x[i]:6:2,' ');
end;
writeln;
min:=x[1];
for i:=2 to n do
if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.
Пример:
Исходный массив:
-7.84 -9.97 7.00 -8.26 -7.71 -3.88 7.59 -2.32
min= -9.97
Измененный массив:
-9.97 -9.97 7.00 -9.97 -9.97 -9.97 7.59 -9.97
Дано:
Математическое выражение:
«(89+75)−2(72:(3+7))»
Найти:
Значение выражения и округлить его в MS Ecxel.
Формула (Её нужно ввести в окошко Excel и нажать "Enter"):
«=ОКРУГЛ((89+75)-2*(72/(3+7));2)»
ответ:
149,6
(До сотых программа округлить не может, ибо число имеет только десятые в ответе)
Далее скриншот, и файл Excel в котором формула и сам ответ.