В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу на языке паскаль которая выводит на экран значение выражения 15i(x+y). Значение целой переменной i и вещественных переменных x, y считываются с клавиатуры.

Показать ответ
Ответ:
tenoruk77
tenoruk77
21.02.2021 18:43

Оператор mod возвращает остаток от деления. Четное число – такое, остаток от деления которого на 2 равен нулю.

Функция int возвращает целую часть дробного числа. С её можно реализовать mod (\texttt {a mod b} – примерно то же самое, что и \texttt{a - b * int(a / b)}) или сравнить результат умножения на 2 целой части результата деления исходного числа на 2 с исходным числом.

Код:

begin

   var a := ReadInteger();

   writeln(a mod 2 = 0);

   writeln(a - 2 * int(a / 2) = 0);

   writeln(a = 2 * int(a / 2));

end.


Пример ввода:

5

Пример вывода:

False

False

False


Пример ввода:

42

Пример вывода:

True

True

True

0,0(0 оценок)
Ответ:
kakniet
kakniet
23.03.2020 00:31
1) д , 2) в . Наверно , мое личное мнение.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота