В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nadyayde
nadyayde
05.10.2020 14:20 •  Информатика

Напишите программу определяющую является ли цифры в двузначном числе нечетными Python​

Показать ответ
Ответ:
YanaDovgik
YanaDovgik
23.01.2021 18:56

Program lol;

Var

 x : array[1..3] of real;

 y : array[1..3] of real;

 a,b,c,p,s : real;

begin

 write('Введите координаты точки А: ');

 readln(x[1],y[1]);

 write('Введите координаты точки B: ');

 readln(x[2],y[2]);

 write('Введите координаты точки C: ');

 readln(x[3],y[3]);

 

 a := sqrt((x[1]-x[2])**2 + (y[1]-y[2])**2);

 b := sqrt((x[1]-x[3])**2 + (y[1]-y[3])**2);

 c := sqrt((x[2]-x[3])**2 + (y[2]-y[3])**2);

 p := (a + b + c) / 2;

 s := sqrt(p * (p-a) * (p-b) * (p-c));

 writeln('Площадь тр-ка S = ', s);

end.

Результат:


Паскаль!! Даны координаты вершин треугольника АВС. Найти его площадь. Данные для самопроверки резуль
0,0(0 оценок)
Ответ:
Grechk
Grechk
07.09.2020 16:30

#include <iostream>

#include <vector>

using namespace std;

int len(int N){

   int cnt = 0;

   while(N > 0){

       cnt++;

       N /= 10;

   }

   return cnt;

}

void swap_digits(int &N){

   string tmp;

   while(N > 0){

       tmp += N % 10 + '0';

       N /= 10;

   }

   N = stoi(tmp);

}

int main(){

   int n;

   cin >> n;

   vector<int> elems1, elems2;

   for(int i = 0; i < n; i++){

       int x;

       cin >> x;

       if(len(x) == 1)

           elems1.push_back(x);

       else if(len(x) == 2){

           swap_digits(x);

           elems2.push_back(x);

       }

   }

   for(auto &i : elems1)

       elems2.push_back(i);

   for(auto &i : elems2)

       cout << i << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота