В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LidaTetyorkina
LidaTetyorkina
21.08.2022 09:03 •  Информатика

Напишите программу решения следующей : создать двумерный динамический массив произвольного размера .ввести значения элементов массива.найти значение минимального элемента массива,поменять его местами с первым элементом

Показать ответ
Ответ:
mitienko811
mitienko811
10.10.2020 05:05

#include <iostream>

#include <time.h>

using namespace std;

int main()

{

srand(time(0));

int a, b;

int min = 100, posI, posJ;

cin >> a >> b;

int** matrix = new int*[a];

for (int i = 0; i < a; i++)

 matrix[i] = new int[b];

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  matrix[i][j] = rand() % min;

}

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  cout << matrix[i][j] << '\t';

 cout << endl;

}

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  if (matrix[i][j] < min)

  {

   posI = i;

   posJ = j;

   min = matrix[i][j];

  }

}

matrix[posI][posJ] = matrix[0][0];

matrix[0][0] = min;

cout << endl;

for (int i = 0; i < a; i++)

{

 for (int j = 0; j < b; j++)

  cout << matrix[i][j] << '\t';

 cout << endl;

}

for (int i = 0; i < a; i++)

 delete[] matrix[i];

delete[] matrix;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота