Нужна по информатике. Язык - Паскаль. Программа пишется в приложении Lazarus файл типа "Программа". сдать нужно сегодня до 11:59.
Составить программу, включающую меню из четырех пунктов: 1.Создать тексто-вый файл из нескольких (не менее трех) строк-предложений. 2.Вывести содержи-мое файла на экран. 3.Подсчитать и вывести на экран и записать в конец файла количество слов, начинающихся с буквы 'z' и заканчивающихся буквой 'd'. 4.Выход. Первые три пункта меню реализовать в процедурах, которые поместить в модуль.
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin
If SunnyDay[i] = True
ThenBegin
a := a + 2;
If a > b Then
a := b;
End
Else
Begin
a := a - 10;
If a < 0 Then
a := 0; End;
End; WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do
Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
End.
10 Мбайт / X = 2 621 440 бит/c
10 * 1024 * 1024 * 8 бит / X = 2 621 440 бит/c
83 886 080 бит / x = 2 621 440 бит/c
X = 83 886 080 бит / 2 621 440 бит/c = 32 c
ответ: За 32 секунды.
2) Пусть наибольший размер файла, который может быть передан через соединение со скоростью 256 000 бит/с за 10 минут, равен X. Следовательно, имеем уравнение:
X / 10 мин = 256 000 бит/c
X / 10 * 60 с = 256 000 бит/с
X / 600 c = 256 000 бит/с
X = 256 000 бит/с * 600 с = 153600000 бит = 19200000 байт = 18750 Кбайт
ответ: наибольший размер файла – 18750 Кбайт
3) В 2 байтах может уместится 65 536 разных значений, а именно столько разных цветов мы имеем. Значит, для хранения каждого пикселя нам надо 2 байта. 1024x800 = 1024*800 = 819 200 пикселей, а соответственно 2 * 819 200 = 1 638 400 байт.
Пусть время, за которое передают файл размером 1 638 400 байт со скоростью 102 400 бит/c, равно X. Следовательно, имеем уравнение:
1 638 400 байт / X = 102 400 бит/c
1 638 400 * 8 бит / X = 102 400 бит/c
13107200 бит / X = 102 400 бит/с
X = 13107200 бит / 102 400 бит/с = 128 c
ответ: 128 секунд.