В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LogiutNowakk
LogiutNowakk
04.07.2021 12:04 •  Информатика

Нужно написать код к программе на языке с. создать файл, содержащий информацию о результатах спортивных соревнований. структура записи: вид спорта, фамилия участника, номер группы, количество набранных участником . составить программу, которая выдает следующую информацию: - общее количество , набранных студентами каждой группы с определением группы победителя; - фамилии участников по указанному виду спорта; - фамилии победителей по отдельным спорта (1, 2, 3 - место).​

Показать ответ
Ответ:
danilgrekov20
danilgrekov20
12.12.2022 20:20
//Видимо, это одна задача, так как "изменения" во второй не указаны
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=20;

Var
 ar:array[1..n] of integer;
 i:integer;
begin
 randomize;
 writeln('First array:');
  for i:=1 to n do
   begin
    ar[i]:=random(10)-3;
    write(ar[i]:4);
    if ar[i]>0 then ar[i]:=ar[i]*2 else ar[i]:=0;
   end;
 writeln;
 writeln('Final array:');
  for i:=1 to n do
   write(ar[i]:4);
end.

Пример работы программы:
First array:   2  -3   5   6  -3  -3   1  -2  -3   1   3  -3   4  -3   1  -1   6   6   2   3
Final array:   4   0  10  12   0   0   2   0   0   2   6   0   8   0   2   0  12  12   4   6
0,0(0 оценок)
Ответ:
Gerty21
Gerty21
24.12.2021 12:22
//Сделал Лугачев Кирилл
//Специально для
//Все данные вводятся с клавиатуры
program Sravnenie;
var   
a, b: integer; // Стороны 1-ого прямоугольника 
d, c: integer;// Стороны 2-ого прямоугольника 
S1, S2: integer; // Площадь 
buf: integer;// Если площадь 1-ого будет меньше 2-ого                
                   //поменяем местами,что бы избавиться от минуса 
razn: integer; // Разница 2-ух площадей

begin   
Write('Введите стороны 1-ого прямоугольника: '); 
Readln(a, b);
   
Write('Введите стороны 2-ого прямоугольника: '); 
Readln(d, c);   
S1 := a * b; //Площадь 1-ого 
S2 := d * c; //Площадь 2-ого   
if S1 < S2 then  
begin   
buf := S1;   
S1 := S2;   
S2 := buf; 
end;   
razn := S1 - S2;    
Writeln('Площадь 1-ого больше площади 2-ого в - ',razn, ' раз');  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота