В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
xoxoberrmi11
xoxoberrmi11
24.03.2023 12:20 •  Информатика

Нужно написать программу, которая определяет, является ли целое число простым. на уровне 9 класса, попроще что бы было. в паскале. заранее !

Показать ответ
Ответ:
zavirohinoleksa
zavirohinoleksa
08.10.2020 14:55
Program p1;
uses crt;
var a,b:integer;
begin
read(a);

   If (a mod 2 = 0) and (a <> 2) or (a mod 3 =0)and (a <> 3) or (a mod 5 = 0) and (a <> 5)or (a mod 7 = 0)  and (a <> 7) then
   write(a,' непростое число')
     else
       write(a ,' простое число');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота