В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
PollyFoxk2002
PollyFoxk2002
03.05.2020 10:30 •  Информатика

Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных элементов.
15.1. Ввести массив с клавиатуры.
15.2. Найти минимальный положительный элемент.
15.3. Вычислить сумму четных элементов массива.
15.4. Вывести массив на экран в обратном порядке.

Показать ответ
Ответ:
Darynaost
Darynaost
19.12.2020 14:54

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

int main() {

vector<int> arr;

int size, min(9999999), sum(0);

cout << "N: ";

cin >> size;

for (int i = 0; i < size; ++i) {

 int temp;

 cout << "Element #" << i + 1 << ": ";

 cin >> temp;

 arr.push_back(temp);

 if (temp >= 0 && temp < min) {

  min = temp;

 }

 if ((i + 1) % 2 == 0) { // нумеруем элементы с 1

  sum += temp;

 }

}

cout << "Min: " << min << endl;

cout << "Sum: " << sum << endl;

for (int i = arr.size()-1; i>=0; --i) {

 cout << arr[i] << " ";

}

}


Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных элементов. 15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота