В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zahar64
zahar64
29.08.2021 20:10 •  Информатика

Объясните : с клавиатуры вводится трёхзначное число. написать программу, которая составляет новое трёхзначное число, в котором цифры десятков и сотен поменяли местами. заранее большое !

Показать ответ
Ответ:
drovac
drovac
07.06.2020 22:53

Объяснение:

тут есть маленькая хитрость

Если записать число не как число а как строку то оно будет восприниматься как слово.

program bred;

var

x :string;

begin

writeln('Введите число': );

readln(x);           -    мы получаем число

writeln(x[2],x[1],x[3]); - указываем какую цифру мы берем и на какое место ставим

end.

Все! Удачи! Отметь этот ответ лучшим!

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота