В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
elizavetdu04
elizavetdu04
11.01.2021 15:21 •  Информатика

Pascal ABC. В файле в столбик записаны целые числа, сколько их – неизвестно. Напишите программу, которая определяет длину самой длинной цепочки идущих подряд одинаковых чисел и выводит результат в другой файл напишите подходящую программу.
10 класс.

Показать ответ
Ответ:
ярик471
ярик471
06.09.2020 14:15

Объяснение:

program zadacha;

var d, o: text;

i, j, k, m, s: integer;

 begin

 assign(d, 'c:\data.txt');

 reset(d);

 assign(o, 'c:\output.txt');

 rewrite(o);

 i := 1;

 j := 1;

 readln(d, m);

 s := m;

 while not(eof(d)) do

 begin

     readln(d, k);

     if k = m

       then i := i + 1

       else

         begin

           if i > j then

             begin

               s := m;

               j := i

             end;

           m := k

         end;

   end;

 writeln(o, 'Число: ', s, ', длина цепочки: ', i);

 close(d);

 close(o)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота