В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nuruk04
Nuruk04
13.08.2021 10:59 •  Информатика

Паскаль.авс
заданы три точки на плоскости a(x1,y1), b(x2,y2) и c(x3,y3). нужно определить, можно ли провести треугольник через эти три точки. если да, то составьте программу вычисления площади по формуле герона.
паскаль

Показать ответ
Ответ:
yulia14683
yulia14683
08.10.2020 21:08

function len(A, B: (integer, integer)): real;

begin

 result := Sqrt((A[0] - B[0]) ** 2 + (A[1] - B[1]) ** 2);

end;

function geron(a, b, c: real): real;

begin

 var p := (a + b + c) / 2;

 result := Sqrt(p * (p - a) * (p - b) * (p - c));

end;

begin

 var (x1, y1) := ReadInteger2(); // или ReadReal2() на ваш выбор

 var (x2, y2) := ReadInteger2();

 var (x3, y3) := ReadInteger2();

 var a := len((x1, y1), (x2, y2));

 var b := len((x2, y2), (x3, y3));

 var c := len((x1, y1), (x3, y3));

 if a + b + c > max(a, max(b, c)) * 2 then

   Writeln(geron(a, b, c))

 else

   Writeln('треугольник не существует')

end.

Объяснение:


Паскаль.авс заданы три точки на плоскости a(x1,y1), b(x2,y2) и c(x3,y3). нужно определить, можно ли
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота