В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Питон У Аркадия есть друг Стас. Стас в последнее время часто работал из дома и редко ходил гулять, зато подписался на страничку с рецептами быстрых пирогов в Инстаграме. История такова: Стас слегка располнел за последний год, поэтому теперь он хочет начать заниматься спортом и вести учёт калорий. Ведь здоровье дороже всего!

С клавиатуры вводятся 7 вещественных чисел - количество калорий, съеденных Стасом за последнюю неделю. Нужно считать данные с клавиатуры и записать их в список. Затем вывести на экран при команды: print(список).

Формат входных данных
С клавиатуры вводятся 7 вещественных чисел. Каждое с новой строки.

Формат выходных данных
Список.

Показать ответ
Ответ:
damirnikiforov
damirnikiforov
27.12.2021 01:00

a = []

for i in range(7):

   x = float(input())

   a.append(x)

print(a)

0,0(0 оценок)
Ответ:
elizavetamalik1
elizavetamalik1
27.12.2021 01:00

Первый вариант решения:

a=float(input())

b=float(input())

c=float(input())

d=float(input())

e=float(input())

f=float(input())

g=float(input())

my_list=[a,b,c,d,e,f,g]

print(my_list)

Второй вариант решения:

my_list=[]

for i in range(7):

   c=float(input())

   my_list.append(c)

print(my_list)

Объяснение:

В первом варианте решения мы просто вводим семь переменных. Потом мы добавляем список (my_list) и ставим [] , так как список так пишется. Вызываем список: print(my_list)

Во втором варианте решения мы пишем название списка(my_list), вводим семь переменных, но уже через for i in range, создаем новую переменную(c=float(input())) , играющую функцию хранилища. Добавляем функцию append (в переводе с английского "добавлять") и прививаем ее к списку с переменной с (my_list.append(c)). Выводим список(print(my_list))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота