В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Makc457214
Makc457214
27.03.2021 09:40 •  Информатика

Питон Условие
В классе учится n учеников. Известен рост каждого из них в сантиметрах. Рост мальчиков по условию задан отрицательными числами. Определите средний рост мальчиков и средний рост девочек.

Формат входных данных
Вводятся целое число n (2≤n≤40) и n целых чисел, определяющие рост каждого ученика.

Известно, что в школе нет ни одного ученика ростом выше 300 сантиметров и ниже 30. Также известно, что в каждом классе учится хотя бы одна девочка и хотя бы один мальчик.

Формат выходных данных
Требуется вывести два целых числа через пробел — средний рост мальчиков и средний рост девочек. Оба числа требуется округлить вниз до целого числа

Показать ответ
Ответ:
03721
03721
20.02.2022 06:00

Программа:

Python:

arr = []

n = int(input('Количество учеников: '))

countMan, countWomen, sumMan, sumWomen = 0, 0, 0, 0

print(f'Введите рост {n} учеников')

for i in range(n):

   height = int(input())

   if abs(height) > 300 or abs(height) < 30:

       print('Введите правильные данные')

   else:

       if height < 0:

           countMan += 1

           sumMan += height

       else:

           countWomen += 1

           sumWomen += height

print(abs(int(sumMan/countMan)), int(sumWomen/countWomen))

0,0(0 оценок)
Ответ:
frikadel1
frikadel1
20.02.2022 06:00

n = 1

li = []

while n<2 or n>40:

   n = int(input("Input n: "))

for i in range(n):

   h = int(input("Input h: "))

   li.append(h)

boys = 0

girls = 0

b=0

g=0

for i in li:

   if i<0:

       boys+=i

       b+=1

   else:

       girls+=i

       g+=1

boys//=b

girls//=g

print(f"Средний рост мальчиков {abs(boys)} см, \nСредний рост девочек {girls} см")

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота