В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
FJFJKD99
FJFJKD99
21.07.2022 12:42 •  Информатика

Программа в pascalabc даны две точки в плоской прямоугольной системе координат. напишите программу, которая позволяет вводить с клавиатуры координаты точек, вычислять расстояние их до начала координат и определять - которая из точек (первая или вторая) находятся ближе к началу координат.

Показать ответ
Ответ:
aman196oyl319
aman196oyl319
05.10.2020 09:45
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

type
  Point=(real,real);

procedure GetPoint(var Q:Point);
begin
  var a,b:real;
  Write('Введите координаты точки: '); Read(a,b);
  Q:=(a,b)
end;

function Distance(a:Point):=Sqrt(Sqr(a[0])+Sqr(a[1]));

begin
  var a,b:(real,real);
  GetPoint(a);
  GetPoint(b);
  var d1:=Distance(a);
  var d2:=Distance(b);
  if d1<d2 then Writeln('Первая точка ближе')
  else
    if d1>d2 then Writeln('Вторая точка ближе')
    else Writeln('Точки равноудалены')
end.

Пример
Введите координаты точки: 13.7 -11.25
Введите координаты точки: 18 12.4
Первая точка ближе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота