В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
orxanalizade894
orxanalizade894
10.04.2023 03:52 •  Информатика

Простое число
напишите программу, которая определяет является ли введенное число простым. если число простое выводиться "" иначе "нет". гарантируется что введенное число больше 1.

sample input 1:

3
sample output 1:

3 - простое
sample input 2:

4
sample output 2:

нет
питон через while

Показать ответ
Ответ:
dima1031
dima1031
02.05.2020 16:52

Массив - это множество однотипных элементов, объединённых общим именем и занимающих в компьютере определённую область памяти. Количество элементов в массиве всегда конечно. В общем случае массив - это структурированный тип данных, состоящий из фиксированного числа элементов, имеющих один и тот же тип.

Другими словами можно сказать, что массив представляет собой фиксированное количество упорядоченных однотипных компонент, снабженных индексами, т.е. является совокупностью конечного числа данных одного типа. В качестве элементов массива можно использовать любой тип данных, поэтому вполне правомерно существование массивов записей, массивов указателей, массивов строк, массивов и т.д.

Массивы могут быть:

одномерными (одна строка – несколько столбцов);

многомерными (несколько строк – несколько столбцов).

Для создания массива его предварительно необходимо описать либо в разделе var, либо в разделе type. Для задания массива используется зарезервированное слово array, после которого указывается тип индекса (-ов) компонент (в квадратных скобках) и после слова of - тип самих компонент!

0,0(0 оценок)
Ответ:
valera20035
valera20035
24.08.2021 20:27

Відповідь:

#include <iostream>

#include<string>//для std::string,length()

#include<iomanip>//для std::setw()

struct kid{

std::string name;

bool gender;

float height;

};

int main(int argc, char** argv) {

struct kid kids[]={

 "Tom",1,1.34,

 "Sara",0,1.54,

 "John",1,1.65,

 "Kate",0,1.86,

 "Emily",0,1.53,

 "Lily",0,1.57,

 "Oscar",1,1.76,

 "James",1,1.73,

 "William",1,1.71,

 "George",1,1.67,

 "Noah",1,1.61,

 "Leo",1,1.75,

 "David",1,1.71,

 "Albert",1,1.68,

 "Austin",1,1.84,

 "Mia",0,1.65,

 "Ruby",0,1.64,

 "Scarlett",0,1.54,

 "Isabelle",0,1.45,

 "Ellie",0,1.65

};

double medium=0.0;

int n=sizeof(kids)/sizeof(kids[0]);

int t=0;

for(int i=0;i<n;i++){

 std::cout<<kids[i].name<<std::setw(12-kids[i].name.length())<<kids[i].gender<<std::setw(7)<<kids[i].height<<std::endl;

 if(kids[i].gender==true){

 medium+=kids[i].height;t++;}

}

medium/=t;

std::cout<<"\nMedium height of boys= "<<medium<<std::endl<<std::endl;

for(int i=0;i<n;i++){

 if(kids[i].gender==1){

  if(kids[i].height<medium){

   std::cout<<kids[i].name<<std::setw(12-kids[i].name.length())<<kids[i].gender<<std::setw(7)<<kids[i].height<<std::endl;

  }

 }

}

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота