В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
azamaaaaa
azamaaaaa
23.10.2022 18:43 •  Информатика

Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)

Показать ответ
Ответ:
АннаЛітвін
АннаЛітвін
05.10.2020 13:16
# coding: utf-8

'''
Последовательность состоит
из натуральных чисел и завершается
числом 0. Определите, сколько
элементов этой последовательности
больше предыдущего элемента.

Python 3.X.
'''

prev = int(input()) # ввод первого элемента
count = 0 # изначально 0 элементов

while True:
    n = int(input()) # ввод числа
    if n == 0:
        break # выход, если 0
    if n > prev:
        count += 1
    prev = n # смещение числа

print(count, "эл.")
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота