В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
4elo100
4elo100
28.08.2020 11:02 •  Информатика

решить

Написать программу вычисления действительных корней биквадратного уравнения:
Ax4+Bx2+C=0
Коэффициенты A,B,C за у пользователя. Учесть, что A, B и С могут быть равными нулю.
В отчет включить:
Описание операторов, обеспечивающих логическое программирование: составной, условный, перехода, выражение.
Полный текст программы для выполнения в среде
MS Visual Studio 2017.

Показать ответ
Ответ:
zybi
zybi
01.04.2022 18:14
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.


program q2;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of real;
Summ:real; // переменная для хранения суммы чисел
MNum:real; // переменная для хранения среднего арифметического
BEGIN
{создание последовательности n отрицательных вещественных чисел}
Writeln('Случайные отрицательные вещественные числа: ');
for i:=1 to n do
begin
mass[ i ]:=((random(9)+1)+(random(9)+1)/10)*(-1); //присваеваем переменной случайное вещественное от 1 до 10
write(mass[ i ],'; '); //выводим
end;
{Вычисление среднего арифметического}
for i:=1 to n do
Summ:=Summ+mass[ i ]; // высчитываем произведение
MNum:=Summ/n;

{Вывод результатов}
writeln;
writeln('Среднее арифметическое: ',MNum);
END.
0,0(0 оценок)
Ответ:
James0123
James0123
01.02.2020 21:11
В ячейку А1 вписываете первое трехзначное число.
В ячейку В1 вписываете формулу =СУММПРОИЗВ (ОКРВНИЗ (ОСТАТ (A1/2^(СТРОКА ($1:$10)-1);2);1)*10^(СТРОКА ($1:$10)-1))
В А2 - второе число, в А3 третье число и т. д. Ячейку В1 с формулой копируете по количеству чисел в колонке А.
Формула у меня получилась короче программы на встроенном в Excel языке программирования VBA, которая делает тоже самое.
Все что выше относится к Excel 2003.
Начиная с Excel 2007 среди встроенных функций есть ДЕС. В. ДВ Как ее использовать см Help.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота