Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
sleta1998A
08.08.2021 15:40 •
Информатика
Решить с паскаля. вычислить значения функции: z=ln(x),если x> =1; z=1,если -1
Показать ответ
Ответ:
помогитесдомашкой3
03.10.2020 22:46
Формула несколько не совсем понятна, но если что функцию не трудно переделать
var
x: real;
function Z(x: real): real;
begin
if x >= 1 then
Z := ln(x)
else
Z := 1;
end;
begin
x := 1;
writeln('z(', x, ') = ', z(x));
x := -1;
writeln('z(', x, ') = ', z(x));
write('x=');
readln(x);
writeln('z(', x, ') = ', z(1));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
murenko20061
23.03.2021 08:35
Рассмотрите пример программы example_7.pas (рис. 2.23), которая из чисел от 10 до 99 выводит суммы цифр, равных n (0 первая цифра числа k, р2 — вторая цифра числа k, s — сумма...
akmaralwellcom
27.03.2022 01:05
Дана последовательность чисел. 0-остановка последовательности. найти процент чисел, кратных пяти. (решить через repeat untill)...
патося37
28.10.2020 09:29
Дописать программу в паскаль. ниже. не знаю как сделать ее со скобками. напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются...
StasDvorchuk
22.06.2022 08:24
Фото зверхускласти програму у PYTHON >...
КлименковЛеонид
21.08.2021 16:57
Написать программу вычисления выражения: не(pred(c) или (ord(c)= при c= folse...
алёнааепар
08.08.2022 20:16
Вася стоит на первой ступеньке свежепокрашенной лестницы и собирается подняться на самую верхнюю, двенадцатую ступеньку. некоторые ступеньки лестницы, а именно, ступеньки...
Данил1901
29.09.2020 21:26
Ваня придумал новый алгоритм сортировки и сейчас тренируется на кубиках с цифрами, чтобы понять, как он работает. перед ним на столе лежат кубики с числами от 1 до 10 (на...
zalehorosaj
13.04.2022 12:44
Ваня придумал новый алгоритм сортировки и сейчас тренируется на кубиках с цифрами, чтобы понять, как он работает. перед ним на столе лежат кубики с числами от 1 до 10 (на...
alekseywindas
01.11.2021 09:01
Разделите следующие суждения по группам: общеутвердительные суждения; общеотрицательные суждения; частноутвердительные суждения; частноотрицательные суждения; сложные суждения...
Mister2211
19.04.2021 18:24
Определите время данных предложений и преобразуйте их в коственную речь: charles said our team won the first match mary said the ballet was wonderful may said i liked the...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
x: real;
function Z(x: real): real;
begin
if x >= 1 then
Z := ln(x)
else
Z := 1;
end;
begin
x := 1;
writeln('z(', x, ') = ', z(x));
x := -1;
writeln('z(', x, ') = ', z(x));
write('x=');
readln(x);
writeln('z(', x, ') = ', z(1));
end.