В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

собери схему с подключением 5 светодиодов и напишите программу для бегущих огней согласно следующим алгоритмам​

Показать ответ
Ответ:
ттууппааяя
ттууппааяя
11.04.2020 16:43
Const
  nn=50; // максимальное количество учеников
var
  i,n,sm,sd,km,kd:integer;
  am,ad:real;
  var a:array[1..nn] of integer;
begin
  Write('Введите количество учеников: ');
  Read(n);
  Writeln('Введите рост учеников');
  sm:=0; sd:=0; km:=0; kd:=0;
  for i:=1 to n do
    begin
    Read(a[i]);
    if a[i]>0 then begin sd:=sd+a[i]; Inc(kd) end
    else begin sm:=sm-a[i]; Inc(km) end
    end;
  am:=sm/km; ad:=sd/kd;
  Write('Средний рост мальчиков (',am:0:1,') ');
  if am-ad<=10 then Write('не ');
  Writeln('превышает средний рост девочек (',ad:0:1,') ');
  Writeln('больше, чем на 10 см')
end.
   
Примерное решение

Введите количество учеников: 9
Введите рост учеников
-192 165 -174 179 -172 171 169 170 -170
Средний рост мальчиков (177.0) не превышает средний рост девочек (170.8)
больше, чем на 10 см
0,0(0 оценок)
Ответ:
tenoruk77
tenoruk77
21.02.2021 18:43

Оператор mod возвращает остаток от деления. Четное число – такое, остаток от деления которого на 2 равен нулю.

Функция int возвращает целую часть дробного числа. С её можно реализовать mod (\texttt {a mod b} – примерно то же самое, что и \texttt{a - b * int(a / b)}) или сравнить результат умножения на 2 целой части результата деления исходного числа на 2 с исходным числом.

Код:

begin

   var a := ReadInteger();

   writeln(a mod 2 = 0);

   writeln(a - 2 * int(a / 2) = 0);

   writeln(a = 2 * int(a / 2));

end.


Пример ввода:

5

Пример вывода:

False

False

False


Пример ввода:

42

Пример вывода:

True

True

True

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота