В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
staylent
staylent
30.07.2022 04:35 •  Информатика

Составить блок-схему и написать программу для решения . организовать вычисление значения функции y по формуле y=4x+3/x-1 -√2x+9 для любого заданного значения аргумента x. учесть вывод сообщения о невозможности вычисления значения функции

Показать ответ
Ответ:
hikkaxxx
hikkaxxx
11.06.2020 19:05

Не совсем понятно, что у вас за функция. если там 3/x, то невозможно вычислить значение при х = 0. Если же там 3/х-1, то сообщение о невозможности вычисления нужно выводить при х =1. Если второй, то в блок схеме поменяйте условие на х!=1 вместо х!=0

 

блок схема во вложениях

 

program function;

var x, y: real;

begin

writeln("введите значение х");

readln(x);

if x <> 0 then y:=4*x+3/x-sqrt(2)*x+9 else writeln("Нет значений");

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота