В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
IbroVine
IbroVine
24.04.2023 20:30 •  Информатика

Составить блок схему и написать программу в турбо паскале. .человеку нужно съездить из лондона в эдинбург. расстояние между этими составляет 390 миль. можно ехать на автомобиле марки '' роллс-ройс " либо на автомобиле марки " форд эскорт". "роллс-ройс" расходует 1 галлон бензина на каждые 15 миль
пути. "форд эскорт" расходует 1 галлон бензина на каждые 36 миль пути. сколько будет стоить поездка в эдинбург на "роллс-ройсе", если стоимость 1 галлона бензина составляет x фунтов сколько денег он сбережёт, если вместо этого поедет на машине марки "форд эскорт" нужно съездить из лондона в
эдинбург. расстояние между этими составляет 390 миль. можно ехать на автомобиле марки '' роллс-ройс " либо на автомобиле марки " форд эскорт". "роллс-ройс" расходует 1 галлон бензина на каждые 15 миль пути. "форд эскорт" расходует 1 галлон бензина на каждые 36 миль пути. сколько будет стоить
поездка в эдинбург на "роллс-ройсе", если стоимость 1 галлона бензина составляет x фунтов сколько денег он сбережёт, если вместо этого поедет на машине марки "форд эскорт"?

Показать ответ
Ответ:
Аноним1418
Аноним1418
08.10.2019 20:10

const l=390;

rrashod=15;

frashod=36;

var

x: real;

economy: real;

fcost,rcost: real;

begin

repeat

write('введите стоимость 1 галлона бензина: ');

readln(x);

until x> 0;

rcost: =l/rrashod*x;

fcost:
=l/frashod*x;

economy: =rcost-fcost;

writeln('стоимость поездки на а/м ролс-ройс составляет ',rcost: 0: 2,' p');

writeln('стоимость поездки на а/м форд составляет ',fcost: 0: 2,' p');

writeln(' составляет ',economy: 0: 2,' p');

writeln('нажмите enter для ');

readln;

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота