В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ксюша8800
Ксюша8800
24.02.2022 17:56 •  Информатика

Составить блок-схемы и написать программу для решения задачи Вычислить n!!=1*3*5*..*(последнее нечетное число, меньшее n, если n - четно).

Показать ответ
Ответ:
Hahaha1234567890
Hahaha1234567890
11.04.2022 17:14
Программа с массивом (хотя он тут и не нужен):
var a:array[1..60] of char;
st:string; i,p:integer;
begin
writeln('Введите массив символов:');
readln(st);
writeln('Вот массив:');
for i:=1 to length(st) do 
 begin
 a[i]:=st[i];
 write(a[i]);
 end;
writeln;
st:=' '+st+' ';
p:=pos(' mama ',st);
while p>0 do
 begin
 delete(st,p,6);
 insert(' ded ',st,p);
 p:=pos(' mama ',st);
 end;
writeln('Измененный массив:');
for i:=1 to length(st)-2 do 
 begin
 a[i]:=st[i+1];
 write(a[i]);
 end;
writeln;
end.

Пример:
Введите массив символов:
mama papa okno mama primer baba
Вот массив:
mama papa okno mama primer baba
Измененный массив:
ded papa okno ded primer baba
0,0(0 оценок)
Ответ:
artem759342
artem759342
24.03.2022 17:53
Во первых вычислим сколько битов имеет рукопись автора для этого 16•64•1024•2048=147483648 битов. нам известно что в одном байте 8 битов. из этого следует 147483648:8=131072 байта. в мегабайте 1000000 байтов. из этого 131072:1000000=0,131072 мегабайта рукописи. а еще нам известно что рукопись имеет 2650 иллюстраций по 6 мегабайткаждая.из этого выходит 2650•6=15900 мегабайт
для того чтобы узнать сколько ушло памяти нафлешке 15900+0,131072= 15900,131072≈15900,1311
в одном гиге 1000 мегабайт
15900,1311:1000= 15,9001311 гигабайт. в общем флеш карта заполнена этой рукописью
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота